WordPress: errore aggiornando i Plugin dalla dashboard

“Plugin Upgrade Failing, Cannot Remove Old Plugin” è un errore che è si è presentato recentemente mentre aggiornavo un plugin direttamente dalla dashboard di WordPress e questo l’errore che visualizzavo:

Downloading update from http://downloads.wordpress.org/plugin/xxxxxx.zip
Unpacking the update
Deactivating the plugin
Removing the old version of the plugin
Could not remove the old plugin
Plugin upgrade Failed


wordpress plugins
La soluzione al problema l’ho trovata in un vecchio thread nel sito di supporto di WordPress:

1. Settare i permessi del file wp-config.php file 0644.

2. Proteggere il file wp-config.php aggiungendo nel vostro .htaccess queste linee di codice:


order allow,deny
deny from all

3. Effettuare il Backup del wp-config.php .

4. Editare wp-config.php file e aggiungere le seguenti stringhe:

define(‘FS_METHOD’, ‘ftpsockets’);
define(‘FTP_BASE’, ‘/path/to/wordpress/’);
define(‘FTP_CONTENT_DIR’, ‘/path/to/wordpress/wp-content/’);
define(‘FTP_PLUGIN_DIR ‘, ‘/path/to/wordpress/wp-content/plugins/’);
define(‘FTP_USER’, ‘username’);
define(‘FTP_PASS’, ‘password’);
define(‘FTP_HOST’, ‘ftp.example.org’);

Il post originale della procedura è qui:
http://wordpress.org/support/topic/plugin-upgrade-failing-cannot-remove-old-plugin

Per risolvere invece l’errore che compare a volte dopo un aggiornamento di WordPress “500 internal server error” e la relativa sparizione del sito, ecco un rapido aiuto: www.uploadsblog.com/2009/02/12/wordpress-su-aruba-soluzione-500-internal-server-error

5.00 avg. rating (96% score) - 1 vote
Loading Facebook Comments ...

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *